Tutorials / Tech blog / Geek Zone

Latest Posts

Thursday, November 10, 2016

Error while adding Tomcat 8.5.x server in Eclipse

An error will be experienced while adding Tomcat 8.5.x server (i.e. as New Server) via "Tomcat v8.0" eclipse plugin against Eclipse (e.g. Eclipse version Mars snapshot shown below)

Following is the exact error experienced...

"The Apache Tomcat installation at this directory is version 8.5.5.  A Tomcat 8.0 installation is expected."




For now we need to perform a workaround with a hope that this will be fixed in coming versions /  update.

Eclipse Tomcat plugin parses server info from Apache Tomcat Server installation and compares against its plugin information. So the trick is to fool Eclipse Tomcat plugin by changing its server information.

Follow the below steps :
  • Navigate to path <Tomcat 8.5 installation folder> / lib
  • Open file "catalina.jar" (You can use  7-Zip software)
  • Update server.info property of org/apache/catalina/util/ServerInfo.properties file
Initial file




Modified file




Now, try adding the Tomcat 8.5 server.... happy coding :)

2 comments: